Здравствуйте!
Развернул по windows 7 Docker-toolbox.
Docker-compose поднялся без ошибок.
MySQL запустился.
Phpmyadmin работает.
Однако проект по адресу 192.168.99.100 при открытии выдает forbidden.
Просмотрел тома указанные в docker-compose.yml все пустые.
Как победить проблему?
Что-то с docker-toolbox очень много проблем.
В A
Всем привет, кто-нибудь из девопсов можете пожалуйста подсказать, как себя обезопасить от воровства кодовой базы, всяких утечек, дыр, после развертывания докера на сервере? Может какие рекомендации ? Я просто пока в этом нуль)
Со стороны кода что мог сделать, сделал. А вот в девопсе вообще темный лес для меня все
Буду очень благодарен!!!
Д A Д
у меня на новом сервере (google cloud compute engine) ubuntu 26.04 возникла трабла c angie (nginx), что внутри докер контейнера ни один из этих ip 172.18.0.1, 127.0.0.53 для резолвера не подошел
resolver 127.0.0.11 valid=60s ipv6=off;
Выводит ошибку постоянно и не видит контейнеры в сети.
2026/08/02 13:32:44 [error] 9#9: send() failed (111: Connection refused) while resolving, resolver: 127.0.0.11:53
Не подскажете, какой же адрес тогда юзать? или может вообще с другим чем-то проблема?
D angie хорошо бы в кастмную сеть, а не в дефолтной гонять. создать какую-нибудь docker network create application и потом angie в неё засунуть. вообще, хорошо бы для начала понять что в резолвере указано сейчас, docker exec -it имяконтейнера cat /etc/resolv.conf и если там 127.0.0.11, то может это ещё и проблема с nftables. в новой убунте докерский dns реализован как DNAT правило, которое перенаправляет трафик на динамический порт процесса dockerd. возможно эти правила применились некорректно, или есть конфликт с ufw / systemd-resolved может ещё форвардинг пакетов заблокирован, нужно чтобы net.ipv4.ip_forward был 1 а если в резолвере внешний днс (8.8.8.8, или аплинка, или 169.254.169.254) то надо делать кастомную сеть как выше - т.к. контейнер в дефолтной сетиM $ sudo docker exec -it angie cat /etc/resolv.conf # Generated by Docker Engine. # This file can be edited; Docker Engine will not make further changes once it # has been modified. nameserver 127.0.0.53 search europe-north2-b.c.project-8305b18b-f213-496f-8fa.internal c.project-8305b18b-f213-496f-8fa.internal google.internal options edns0 trust-ad # Based on host file: '/etc/resolv.conf' # Overrides: []
Доброго времени суток всем, проблема такая: есть впн развернутый на хосте и docker; также сконфигурированы iptables, чтобы трафик из впн сети мог гулять как в стандартные сети docker 172.xxx так и в пользовательские docker сети (10.xxx/16) соотвественно и обратно. Но с хоста я могу получить доступ к контейнерам по их внутренним ip, а с машины подключенной к этому впн только к шлюзу пользовательской docker сети. Кто с таким сталкивался, дайте хелпы, пожалуйста