Добрый день. Запрос фичи. В истории сообщений не нашел. Можно ли добавить функцию удаления всех комментариев маркера. Когда это может пригодиться?! Например кейс. Идёт плановая работа над разметкой кода, несколько разработчиков имеют разное мнения на проблему, ставят разные комментарии. Потом приходят другие разработчики, делают ревью. В конеце-концов формулируется конечное объяснение и комментарий, почему поставили won't fix или false positive. Для результирующего отчёта хочу оставить только один правильный комментарий. Желаемое действие в этой ситуации: удалить все комментарии, написать единственный согласованный, который и попадёт в отчёт.
Спасибо!
Подскажите, это правильный скрипт для публикации анализа на Svacer через REST API?
zip -r analysis.zip .svace-dir
curl -X POST \
"https://svacer.example.com/api/public/svace/import" \
-H "Authorization: Bearer $TOKEN" \
-F "[email protected]" \
-F "project=MyProject" \
-F "branch=main"
да, должен сработать. Есть еще пример на Go https://gitlab.ispras.ru/svacer-public/api-go-examples/-/tree/master/upload-svace-dir?ref_type=heads
только перед использованием API необходимо чтоб svacer-server был запущен с указанием пути к svace-у (для импорта требуется)
S Архив svace-dir получается ~500 Мб. Сервер возвращает ошибку: 413 Request Entity Too Large Я отправляю запрос на https://svacer.example.com то есть на порт 443 (сервер не локальный). В примере на Go запрос идет на порт 8080. Подскажите, что я делаю не так.
Реализованы команды для сохранения и загрузки конфигурации сервера (пользователи, роли, проекты, группы проектов). Получить конфигурацию можно с помощью команды svace server admin list --all --json, загрузить можно при начальной инициализации сервера с помощью команды svace server init --config path.json.
Это же получается, что появился полноценный функционал для создания бэкапа и восстановления сервера удаленного анализа?
А своих правила можно будет писать только с помощью Svace Light API? (удалена поддержка SvaceIR API)
Здравствуйте, подскажите, пожалуйста, где я ошибся.
Был сервер 5.0.260306, к нему добавлял через remote-add-distro (локально) еще и 5.0.260414, 5.0.260525. При подключении клиента на порт оно само выбирало версию сервера в зависимости от версии клиета, хотя и упоминало 5.0.260306 в логе.
svace remote --host xxx --port xxx analyze
No weight in command line. Using default weight for tasks: 1
No default-group in command line. Using default value: xxx
No path in command line. Using current folder: 'xxx'
No HTTP port in command line. Using default remote port: 8060
[INFO] No database for svace project directory; initializing new one
Loaded '/usr/lib/svace-5.0.260525-x64-linux/config/settings.txt'
Loaded '/usr/lib/svace-5.0.260525-x64-linux/config/warn-settings.txt'
No build ID provided, using last successful build
Starting remote analysis task '6e46a9d995dfcb44a9f628613f190b6796e4384e' on remote server.
No ssl certificate is set
Server has the same protocol version.
[SUCCESS]ransferred: 21, 0.3Mb
License is available for 364 days.
Loaded '/usr/lib/svace-5.0.260306-x64-linux/config/settings.txt'
Loaded '/usr/lib/svace-5.0.260306-x64-linux/config/warn-settings.txt'
Analyzer version: 5.0.260306 (git rev a23fcb5788a43fc98469f317bae11f65a9e0bc4f 2026-03-06 20:07:05 +0300)
Input producer version: 5.0.260525 (git rev c025f254b2e3c65c6b31a1e6dbe8360beecfd6ab 2026-05-25 11:31:17 +0300)
LLVMParse version: 'Version 3.14.0. (LLVM 16.0).'.
Skipping SharpChecker analysis because no stored data for SharpChecker found.
...
Пробую продолжить это же с 6.0:
/usr/lib/svace-5.0.260306-x64-linux/bin/svace server \
--server-dir /svacesystemd/server-common admin remote-add-distro \
--name 6.0.260714 --version 6.0.260714 --path \
/usr/lib/svace-6.0.260714-x64-linux/
remote-show:
Version: 5.0.260306
Name: 5.0.260306
Distro path: /usr/lib/svace-5.0.260306-x64-linux
Version: 5.0.260414
Name: 5.0.260414
Distro path: /usr/lib/svace-5.0.260414-x64-linux
Version: 5.0.260525
Name: 5.0.260525
Dist
D D Что-то эффекта нет: все равно пытается 5.0 использовать. # svace remote --distro-name 6.0.260714 --host xxx --port xxx analyze No weight in command line. Using default weight for tasks: 1 No default-group in command line. Using default value: xxx No path in command line. Using current folder: 'xxx' No HTTP port in command line. Using default remote port: 8060 Loaded '/usr/lib/svace-6.0.260714-x64-linux/config/settings.txt' Loaded '/usr/lib/svace-6.0.260714-x64-linux/config/warn-settings.txt' No build ID provided, using last successful build Starting remote analysis task '87bcaebcc7b6ce694f5e5f780e0b93ba5c1b3784' on remote server. No ssl certificate is set Server has the same protocol version. [SUCCESS]already exist License is available for 363 days. Loaded '/usr/lib/svace-5.0.260306-x64-linux/config/settings.txt' Loaded '/usr/lib/svace-5.0.260306-x64-linux/config/warn-settings.txt' Analyzer version: 5.0.260306 (git rev a23fcb5788a43fc98469f317bae11f65a9e0bc4f 2026-03-06 20:07:05 +0300) Input producer version: 6.0.260714 (git rev 85c700ad5079eb0e74b45b4c4045244adc430615 2026-07-21 01:29:32 +0300) LLVMParse version: 'Version 3.14.0. (LLVM 16.0).'. Error: Bitcode producer LLVM version 'LLVM20.1.8-ispras-1.0' doesn't match expected LLVM version 'LLVM16.0.6-ispras-1.0'. Terminating analysis due to incompatibility with the input producer. svace analyze: error: Svace analyzer exited with code 31 [FAILED]Analysis failed: The process returned with error code: 31 Analysis failed: Analysis finished without any results.
Добрый день, коллеги!
Подскажите, может кто-то знает.
У нас лицензия на USB, и работает только на машине, куда USB вставлена. Для того, чтобы воспользоваться ею на других машинах, пришлось придумать костыли в виде проброса usb-портов.
Возможно ли каким-нибудь образом сделать так, чтобы лицензия распространялась на все машины в локальной сети? И в любой момент, любая машина смогла бы запросить её для средств ИСП РАН?
М Здравствуйте! Установите Sentinel Runtime, распространяемый в комплекте со Svace. В пределах одной подсети работает без дополнительных настроек, за пределами — нужно зайти в Sentinel Admin Control Center (порт 1947) и в разделе Configuration→Access to Remote License Managers вписать имя или адрес сервера с лицензией.I
основные опции --project, --branch, --snapshot для указания куда импортировать и как именовать. Проекты и бранчи создаются автоматически (есть так же опции для контроля как создаются).
Ряд информации описан в https://svacer.ispras.ru/mediawiki/index.php?title=Help:Import_from_Svace
так же можно посмотреть описание в выводе svacer import --help